Acabo de cambiar el proveedor de email saliente ( […]

BEST OF THE BEST Update 20 Agosto ● Windows/Ret[…]

He probado la ROM de LocoRoco de PSP en una 3B+[…]

Muchas gracias, pues seguramente será eso, […]

¿Quieres tener un Servidor o una Nube propia? Este es tu sitio!
#90048
Buenas, es mi primer reporte en este foro y aunque realmente no se trata sobre la RaspBerry, si lo es sobre NAS y concretamente sobre OpenMediaVault. Por ello lo pongo aqui, con la esperanza de que alguien pueda ayudarme.
Tengo OMV 4.1.23 instalado en un pendrive USB 3.0 sobre un sistema ITX con celerom J3455 y 8 GB de RAM, dos HD de 2 TB, el principal de datos formateado en BTRFS y el otro como copia de seguridad en EXT4. He configurado lo que he visto evidente o he leido por internet. En principio todo funciona bien, salvo el automontaje de la unidad de datos compartida.
Tengo una torre y un portatil, ambos con Linux Mint 18.3 Mate y en ambos he configurado el fstab para que se monte la unidad compartida de OMV al arrancar. La unidad se monta y funciona, pero se monta con root como propietario y grupo y por ende no me deja escribir desde mi usuario normal, (si monto la misma unidad desde "explorar la red", si tiene los permisos correctos).
La linea actual en el fstab que la monta es esta:
//172.26.0.252/NAS /media/tanausu/NAS cifs credentials=/root/.acceso_nas 0 0
Pero he probado todas las posibilidades que he visto en internet, sin resultados.
Hice incluso una prueba, asignando todo el disco de datos en el OMV a mi usuario y grupo, pero tampoco me dio resultado.
¿Alguien me puede echar una mano?.
Agradecido de antemano.

Saludos.
Última edición por AcoranTf el |06 Ago 2019|, 22:02, editado 1 vez en total.
Avatar de Usuario
Por tzinm
Pi Newbie
#90052
Añade en la línea fstab el id de usuario y el id de grupo.

Para obtener el id ejecuta en la línea de comandos de OMV el siguiente comando:
Código: Seleccionar todo
id -u username
La línea fstab debería quedarte tal que así:
Código: Seleccionar todo
//172.26.0.252/NAS /media/tanausu/NAS cifs credentials=/root/.acceso_nas,rw,uid=número,gid=número 0 0
El “número” deberás sustituirlo por los datos que has obtenido con el primer comando.

Ya nos dices si te ha funcionado!
AcoranTf les gusta esto