Hola, yo también solicito acceso, si es pos[…]

Hola. Saludos a todos. He probado esta imagen en […]

Solo le encuentro un fallo a esta imagen y es que […]

En teoría, pero por si acaso harás u[…]

Sección dedicada al mediacenter mas utilizado
#92220
¡Hola!

He comprado la nueva Raspberry Pi 4 Modelo B y he instalado Kodi 18.5 para la raspberry pi 4, desde la página oficial y, una vez instalado en una tarjeta micro sdxc, como esta: https://www.amazon.es/gp/product/B07FCM ... UTF8&psc=1 y con esta caja y componentes para la raspberry https://www.amazon.es/gp/product/B07WN3 ... UTF8&psc=1

Resulta que el sonido no se reproduce. Tengo un sistema de audio y no funciona, tampoco con los altavoces de la TV.

He mirado por todos las configuraciones posibles y no encuentro el modo de que se reproduzca. Sin embargo, se ve perfecto, así que no se si se trata de un error de kodi o de la raspberry o si es algo habitual.

Lo único que he leído es que daba problemas en el vídeo la compatibilidad del cable USB-C

¿Alguna solución?

Gracias.

Pd: disculpad, esto debería ir al soporte general de Kodi. Si lo podéis mover allí, gracias.
#92239
egrueda escribió: hace 5 meses Si conectas un altavoz o auriculares a la salida de audio (minijack) y configuras kodi para el audio analógico, ¿tienes sonido por la salida analógica?
MuadDib69 escribió:Hola,
yo he encargado casi lo mismo que tú (aún no lo he montado) pero solo se me ocurre preguntarte si has probado con otro cable HDMI, por si acaso lo que falla es el cable suministrado con la caja, que es sospechosamente barato...
Buenos días, gracias a los dos por la respuesta

Pues he probado a realizar lo que me comentas y si que se escucha por los auriculares. Es decir, que he cambiado la configuración a salida de audio en analógico, he conectado los auriculares y ya reproducía el sonido.

Por lo tanto, el error debería venir exclusivamente de la entrada HDMI, que no sé si es por una mala calidad/incompatibilidad del cable que me llegó con el pack que he comentado. Aunque, de ser así, tampoco debería funcionar el vídeo, ¿no?

O podría ser que tendría que realizar algún otro tipo de configuración.

El cable HDMI lo tengo conectado directamente a la TV. Como tenía una raspberry pi 3 model B+, en el momento que lo conecto a la TV, no tengo que realizar ningún tipo de configuración y el sonido lo detecta automáticamente.

Por último, en el pack también venía una adaptador de micro HDMI a HDMI y lo he probado con el cable que ya tenía conectado a la otra raspberry, pero ocurre igual, no reproduce sonido.

¿Será problema entonces como dice el compañero MaudDib69 del cable HDMI?

He visto estos dos cables:

https://www.amazon.es/UGREEN-Velocidad- ... r=1-3&th=1

https://www.amazon.es/AmazonBasics-Adap ... ics&sr=1-3

¿Alguna otra recomendación?

Muchas gracias por todo.
#92240
El caso es que has probado con el otro cable hdmi (el de la otra raspi) usando el adaptador, y no se oye.
Es decir, has probado con un cable "bueno" hdmi, con adaptador, y no se funciona, entonces parece que no es problema del cable, ¿no? Humm...
Es raro que el mismo cable te esté dando vídeo pero no audio, voy a investigar.

¿Qué sistema tienes instalado? ¿es una raspbian o alguna imagen específica?
¿Arranca en consola o en modo gráfico?
Severus les gusta esto
#92241
egrueda escribió: hace 5 meses El caso es que has probado con el otro cable hdmi (el de la otra raspi) usando el adaptador, y no se oye.
Es decir, has probado con un cable "bueno" hdmi, con adaptador, y no se funciona, entonces parece que no es problema del cable, ¿no? Humm...
Es raro que el mismo cable te esté dando vídeo pero no audio, voy a investigar.

¿Qué sistema tienes instalado? ¿es una raspbian o alguna imagen específica?
¿Arranca en consola o en modo gráfico?
Perdona egrueda, seguramente no me haya explicado bien :apurado

Con el pack con la caja venían dos cables HDMI:

Imagen

He realizado 3 pruebas:

1. Con el cable 1 de la imagen, conectado de la raspberry a la TV. No se reproduce el sonido.
2. Con el adaptador 2 de la imagen. Lo he conectado a otro cable HDMI que ya utilizaba para mi anterior raspberry pi 3. No reproduce el sonido.
3. Tal y como me comentaste, cambié la configuración a salida analógica, conecté unos auriculares. Si reproduce el sonido en los auriculares.

Lo mismo es que el adaptador también es malo y el problema reside en los dos cables que venían con el pack.

Tengo esta versión que ha salido para la pi 4:

https://libreelec.tv/raspberry-pi-4/, grabado con Rufus, por si es necesario el apunte. No es ninguna imagen, directamente, le he ido metiendo algunos addons.

De hecho, he probado con reproducir un vídeo a través de diferentes addons y también desde mi disco duro, pero en todos los casos, no ha reproducido el sonido.

A tu última pregunta, ya me pierdo un poco. Directamente arranca con el logo de Kodi 18.5 y después ya está el menú básico de Kodi.

Un saludo.
#92251
egrueda escribió: hace 5 meses Una pregunta, ¿qué puerto hdmi estás usando?
Yo lo tengo conectado en el HDMI que está más cerca del conector usb de corriente
Pues no sabría decirte, ya no sé si lo he probado en uno u otro. Debería hacer la prueba, en cuanto llegue a casa esta noche, lo hago y lo comento.

Un saludo.
#92263
MuadDib69 escribió:No sé si tendrá relación, pero en este otro hilo hablan de problemas de audio con la segunda conexión HDMI...
viewtopic.php?f=41&t=14145

PD: aún no lo he sacado de la caja (me espero al tío del JOU JOU) y ya estoy acojonao por si no funciona... ;)
Hola! Pues resulta que justo ese ha sido el problema Imagen, resulta que un puerto HDMI no funciona el audio y sin embargo en el otro puerto sí.

Ya no estaba seguro si siempre lo conectaba al mismo puerto y ha sido probarlo de nuevo y funciona a la perfección en el puerto izquierdo. En el derecho no funciona.

Debe tratarse o de un error de fabricación, digo yo y no sé si lo arreglarán con alguna actualización del firmware.

Así que solucionado. Lo único que espero que el segundo puerto, el que su funciona, no lo deje de hacer en el futuro.

Un saludo!

Enviado desde mi MI 6 mediante Tapatalk

#92267
https://www.raspberrypi.org/forums/view ... 4#p1570203
Well well well - guess what? I suddenly realised, that today after moving my Pi setup, I had put the HDMI cable to the connector that sits further away from the power connector. If I remember right, that is HDMI 1, while the connector just beside the power connector is HDMI 0.

So, I shut down the system, plugged my cable to HDMI 0, restarted - and there were sound again! Even without uncommenting the forementioned config option. To be sure, I did the same test with HDMI 1 again - no sound.
Y abajo proponen una solución relacionada con forzar la salida a HDMI en vez de DVI (por lo visto a veces la pi detecta que al otro lado hay un DVI en vez de HDMI)
rwgent wrote: ↑
Sat Oct 05, 2019 6:20 pm
This worked for me:

Edit config.txt

sudo nano /boot/config.txt

Look for these lines:

# uncomment to force a HDMI mode rather than DVI. This can make audio work in
# DMT (computer monitor) modes
#hdmi_drive=2

uncomment the #hdmi_drive=2 just remove the # so it looks like this:

hdmi_drive=2

type: ctrl+o then hit enter to save the changes
then type ctrl+x to exit
reboot and try playing sound
So this worked for me too on a Raspberry Pi4. This had me stumped for a while and I was pretty sure I had a hardware issue as this Pi worked fine for a couple of months then silence! This Pi is on the back of a Phillips "Dumb" TV making it a bit "Smarter" so is handy for YouTube and such like.
I invested in new HDMI cables as I had been using a stubby adaptor which wouldn't fit in HDMI0 beside the USB C, neither of these cables worked in either of the HDMI ports or in any of the HDMI ports of my TV. The only thing that changed on the Pi4 was the addition of a Pimoroni Fan Shim but to stop throttling but it worked for a while after this too! I was fairly sure I had a hardware issue as I had changed nothing on the Pi, perhaps changes due to apt-get update/upgrade?

In any case, forcing the output to HDMI via the config.txt seems to have worked.

Y hay más...

https://github.com/raspberrypi/firmware/issues/1243
Severus les gusta esto
#92288
Yo creo que es global, e imagino que tener 2 HDMI disponibles es para dar salida a doble monitor pero con una única fuente de audio, por lo que igual no se han comido la cabeza en implementar ese audio en el segundo HDMI.
La solución es usar el primero y yo no me voy a calentar la cabeza cuando lo ponga en marcha, esperando que no necesitaré ese audio por el segundo. (cruzo los dedos).

PD: Sugeriría un cambio de título al hilo añadiendo "en el segundo HDMI" para que a los siguientes que visitasen el foro por el mismo problema encontrasen mejor la solución :mmm
#93894
Hola a todos, bueno, os voy a explicar como lo he solucionado yo el problema de la falta de audio de Libreelec en la raspberry pi4.
Lo que he hecho a sido coger la tarjeta sd, meterla en el ordenador (en mi caso sólo uso GNU/LINUX) en todos mis equipos, bueno, no me enrollo , buscamos el archivo llamado:

config.txt

lo abrimos y editamos añadiendo la siguiente linea al final del todo:

#######borrar a partir de aquí en caso de no funcionar########
hdmi_drive=2

Lo que está entre almohadillas es sólo para acordarme a partir de donde he metido mano jejeje, lo verdaderamente importante es la linea que esta SIN renombrar o lo que es lo mismo sin la #
Si queréis hacer la prueba luego probad a poner una almohadilla delante de la solución y vais a ver como volveis a quedar sin sonido.
Una vez hecho esto guardamos los cambios y volvemos a poner la tarjeta en nuestra raspi, si todo ha ido bien debeis tener sonido a traves del hdmi.
Decir que utilizo el puerto que está pegado a la fuente de alimentación.
Espero os sirva, un saludo
#95313
MuadDib69 escribió: hace 5 meses No sé si tendrá relación, pero en este otro hilo hablan de problemas de audio con la segunda conexión HDMI...
viewtopic.php?f=41&t=14145

PD: aún no lo he sacado de la caja (me espero al tío del JOU JOU) y ya estoy acojonao por si no funciona... ;)
:mrgreen: :mrgreen: :mrgreen:
Muchas gracias por la solución compañero.
Es la primera vez que uso Kodi, ya me ha costado un poco configurarlo y llevaba ya unas horitas dándome cabezazos con las configuraciones porque no se oía :destroyer
En un minuto en el foro, estaba solucionado. :? Lástima no haberlo pensado antes!