Raspbian no conecta por SSH

Discusión general sobre Raspberry Pi
Responder
Avatar de Usuario
klingsor
Pi Master
Pi Master
Mensajes: 227
Registrado: 14 Jul 2017, 12:16

Estoy intentando seguir los pasos de esta instalación Mediacenter manual en Raspberry Pi 4 y todo bien mientras estoy conectado por cable y el HDMI de la tele, es decir tengo conexión y he logrado poner ip fija pero no consigo conectarme desde el Mac por terminal a SSH, pongo

Código: Seleccionar todo

ssh pi@192.168.1.***
ssh: connect to host 192.168.1.*** port 22: Connection refused
Y tengo activada la conexión por SSH en Rasbian.

Modelo Raspberry Pi 3B+, Raspbian con escritorio.

Quiero hacer esa instalación sin kodi, solo los programas para descargar y un escritorio para poder conectarme por VNC y borrar archivos en remoto.

Saludos.

---------------

He logrado conectarme cambiando el modo de arranque por defecto de Raspbian, en vez del escritorio la he dejado con el Login automático.

Pero no se conecta con la ip que yo le he asignado sino con la que ella quiere y me gustaría que lo hiciera con la que he puesto, para asignar ip fija he seguido estos pasos:

IP fija Raspbian

¿Por qué no coge esa ip?

Saludos again. 8-)
Avatar de Usuario
egrueda
Pi God
Pi God
Mensajes: 2086
Registrado: 10 Feb 2017, 19:31

A ver, vamos por partes, empezamos con el SSH
El mensaje "port 22: Connection refused" indica que el servicio SSHd no está corriendo en la raspi.
Ejecuta el comando: "sudo systemctl start sshd" y prueba de nuevo a conectar
¿Puedes probar eso y nos cuentas?
Avatar de Usuario
klingsor
Pi Master
Pi Master
Mensajes: 227
Registrado: 14 Jul 2017, 12:16

He intentado lo que me has dicho pero no ha sucedido nada, porque la Raspberry había cambiado de IP.

He reiniciado después de haber hecho un update y al hacerlo me ha asignado una IP distinta a la anterior y ahora me estoy peleando en poner una IP fija en Raspbian, he seguido el tutorial arriba indicado pero no sirve para nada, cada vez que reinicio la Raspberry el router me asigna una IP y así es imposible hacer nada y ya no sé por donde seguir.

El modelo del Router es Router fibra ZTE F680 y creo que los tiros van por que cada vez que detecta una conexión la asigna él y la Raspberry no coge la que le he indicado.
He encontrado esto en el foro de Raspbian y creo que es parte de la solución, pero ni idea de como hacerlo en el Router.

You do need to understand your network addressing and know what your routers IP and DNS server IP's as well, before you can set a static IP.
Your static Ip should also be out side of the address range that your DHCP server in your can assign or you will end up with address conflicts. Aquí puede estar la solución. :idea
The safer and often simpler option is to use reserved IP addressing in your router if it supports it.


Tengo asignada en el Router una dirección a la que quiero en la Raspberry Pi, pero ni con esas me la coge. Mi siguiente intento es borrar dicha IP del Router, y cuando este asigne una a la Raspberry incluirla en el Router y dejar esa como fija (suponiendo que eso sirva).

Estoy por lanzar la Raspberry por la ventana. :destroyer

Saludos.
Avatar de Usuario
egrueda
Pi God
Pi God
Mensajes: 2086
Registrado: 10 Feb 2017, 19:31

Veamos, tu router asigna una dirección IP en un rango, por ejemplo desde la 51 hasta la 100.
Ese rango lo puedes decidir tú desde la configuración del router.

Entonces tienes 2 formas de tener una dirección IP estática en la Raspberry:

Una forma es editando la configuración en la raspi para usar una IP estática, eligiendo una IP que esté en la misma red que el router pero que no esté contenida dentro del rango dinámico que el router para usar para asignar a los otros equipos. Por ejemplo, usando el ejemplo anterior, tendrías que usar una dirección IP de la 50 hacia abajo o de la 101 hacia arriba

Otra opción muy cómoda, creo que es la que tú mencionas, hacer una reserva en el router. De esa forma el router siempre asignará a la misma IP a la misma tarjeta de red del equipo.
Es decir, la IP seguiría siendo dinámica pero siempre te asignaría la misma.

No te desesperes, cambiar la configuración de red de un equipo Linux es muy sencillo si sabemos lo que estamos haciendo.
y si no quieres modificar la configuración, déjalo dinámico en Linux y asignarle una reserva desde el router.

En tu router, esa opción se llama DHCP Binding
unnamed.jpg
No tienes los permisos requeridos para ver los archivos adjuntos a este mensaje.
Avatar de Usuario
klingsor
Pi Master
Pi Master
Mensajes: 227
Registrado: 14 Jul 2017, 12:16

Arreglado, he asignado una IP que no estaba reservada por el Router y ya puedo seguir con las distintas instalaciones.

Ahora toca Transmission, a ver qué me encuentro. :xd

Mi intención es instalar Transmission+Radarr+Sonarr+Bazarr+Jacket junto con Proftp para pasar mis descargas al disco donde las voy guardango.

De momento mi única duda es instalar Radarr y Bazarr ya que para Sonarr y Jackett voy a seguir tu guía, con Radarr he usado las instrucciones de su web adaptado (pastebin) a tu forma de instalación según Sonarr (si tengo algún problema consulto) y con Bazarr voy a seguir las instrucciones que ya me diste hace tiempo por aquí cuando lo instalé en mi anterior instalación (pastebin) sobre DietPi.

Saludos.
Avatar de Usuario
klingsor
Pi Master
Pi Master
Mensajes: 227
Registrado: 14 Jul 2017, 12:16

Todo instalado y funcionando. :mrgreen:
He instalado Deluge en vez de Transmission porque este me daba problemas de permisos de escritura en el disco duro y por más vueltas que daba no encontraba la solución; con el tiempo voy a probar otra vez con Transmission pero de momento dejo esta instalación que funciona todo perfecto.

Me he creado una guía y cuando tenga tiempo la subo al foro por si alguien más quiere tener un box torrent para descargas.

Saludos y gracias.
Responder