La raspi se bloquea muy a menudo

Discusión general sobre Raspberry Pi
Responder
Avatar de Usuario
danpacu
Pi Beta
Pi Beta
Mensajes: 179
Registrado: 27 Nov 2019, 21:42

Buenas tardes.
Tengo todavía varios problemillas con mi raspi 4 de 1 gb de ram.
los enumero:
1. Se bloquea muy a menudo - y cuando intento conectarme a ella por ssh o vnc o por ftp me da error. tengo que resetearla. No entiendo por que me hace esto, ultimamente (estoy hablando de las ultimas dos semanas).
2. desde hace un mes, cuando la reinicio no me arranca de forma automatica la tele (a la cual esta conectada haciendole de monitor si fuera necesario - la verdad es que pocas veces, porque utilizo el vnc o el ssh para "trabajar" en la raspi). si antes cada vez que la reiniciaba me arrancaba la tele, aún estando esta apagada, ahora ya no. No entiendo por que.
3. es normal que al arrancar chromium se muera de lo lento que va la raspi?? me da miedo arrancar el navegador - tarda muchísimo en cargar una pagina, y más de una vez, por vnc tuve que deconectarme o incluso reiniciar la raspi para que funcionase de nuevo (intendano bajar de bookshelf una revista - se bloqueó durnate el proceso de descarga, reincie y resulta que ya tenía descargada la revista). Esto no es normal - ni que pase esto, ni que vaya tan condenadamente lenta con el chromium - por eso que ni lo arranco.

podría alguien indicarme al menos que log he de mirar para encontrar posibles fallos (todo sería con vuestra ayuda, tanto encontrar el log como el fallo, :-D)??
Y sería descabellado preguntar: cuantas veces se deberia reiniciar la raspi en una semana, asumiendo que esta enchufada 24/7, cumpliendo papel de servidor nextcloud, plex y ftp???
perdonad las preguntas, pero no se que hacer exactamente para que no se bloquee cada dos por tres.
Avatar de Usuario
egrueda
Pi God
Pi God
Mensajes: 2086
Registrado: 10 Feb 2017, 19:31

¿Qué tarea estás haciendo cuando se bloquea?
Avatar de Usuario
danpacu
Pi Beta
Pi Beta
Mensajes: 179
Registrado: 27 Nov 2019, 21:42

egrueda escribió:
29 Jun 2020, 00:45
¿Qué tarea estás haciendo cuando se bloquea?
Hola. Nada en especial. Quería conectarme por ssh para borrar un fichero de la carpeta de descargas. Y luego querría comprobar si en la carpeta d e música se había descargado una carpeta de música.
El servidor de Plex no veía dicha carpeta. Cuando le di refrescar se quedo parado. Luego intenté conectarme y nada.
Avatar de Usuario
egrueda
Pi God
Pi God
Mensajes: 2086
Registrado: 10 Feb 2017, 19:31

Según comentas, el último en entrar en el juego fue Plex.
¿Crees que siempre que se bloquea está Plex por medio?
Avatar de Usuario
danpacu
Pi Beta
Pi Beta
Mensajes: 179
Registrado: 27 Nov 2019, 21:42

Bueno, plex está siempre activo, al igual que toda la raspi.
Otra situacion: volví de correr ( escuchando desde plex, música - todo ok). Después de cenar me quise conectar por ssh para hacer un update y comenzar con el “estudio” de docker. Pues no daba señal. Intenté hacer ping a la raspi y error. Tico hacer reset y luego todo perfecto.
Otra tarde: descargue del bookshelf, conectado por VNC un libro. Pues se quedo colgada la raspi. Después del reinicio, el libro ya lo tenía descargado (el problema del navegador, mencionado antes!!).
Intento al menos una vez a la semana hacer sudo update y sudo upgrade. Para tener todo al día.
Esta es de momento mi “realidad”.
Avatar de Usuario
Kike
Administrador
Administrador
Mensajes: 2179
Registrado: 13 May 2016, 18:53
Ubicación: Islas Baleares - Menorca
Contactar:

Por lo que leo parece ser que queda bloqueada porque estará escaneando las bibliotecas en Plex frecuentemente.
¿Podrías detener el servicio de Plex para ir descartando a ver si te quita dichos problemas?

Código: Seleccionar todo

sudo service plexmediaserver stop
Y otra pregunta suponiendo que tuvieras un HDD conectado ¿Que sistema de archivos utiliza el Disco (EXT4,NTFS...)?
Si lo puedes soñar, lo puedes hacer
Avatar de Usuario
danpacu
Pi Beta
Pi Beta
Mensajes: 179
Registrado: 27 Nov 2019, 21:42

Hola, Kike.
Ahora mismo paro el servicio. El hdd esta formateado en ext4.
Probare a quitarle la frecuencia de escaneo de bibliotecas a plex. A ver si consigo hacerlo que me deje solo manual.
Por otro lado, lo de arranque de la tele se me olvido mencionar que es una samsung de 10 años, de 42”, lcd - vamos una tele normal y corriente, sin ser smart tv ni nada parecido. Pero el caso es que ahora no me la arranca al reiniciar la raspi (que me gusta mas así, jeje) pero no entiendo por que antes si y ahora no.

Late edit: plex parado, y mirando por allí le dije que me escanease la biblioteca diariamente, no cada 3 horas. No vi como ponerlo en manual, por así decirlo...
Avatar de Usuario
egrueda
Pi God
Pi God
Mensajes: 2086
Registrado: 10 Feb 2017, 19:31

danpacu escribió:
29 Jun 2020, 15:36
Late edit: plex parado, y mirando por allí le dije que me escanease la biblioteca diariamente, no cada 3 horas. No vi como ponerlo en manual, por así decirlo...
Vamos a ver si quitando a plesk de la ecuación, al menos parcialmente, mejora la cosa.
danpacu escribió:
29 Jun 2020, 15:36
Por otro lado, lo de arranque de la tele se me olvido mencionar que es una samsung de 10 años, de 42”, lcd - vamos una tele normal y corriente, sin ser smart tv ni nada parecido. Pero el caso es que ahora no me la arranca al reiniciar la raspi (que me gusta mas así, jeje) pero no entiendo por que antes si y ahora no.
Hay dos parámetros que hacen esto:
1. A nivel de Raspberry Pi, en el config.txt
2. A nivel de Kodi, en los ajustes.

Lo cual me recuerda que lo tengo activado en casa y cada vez que reinicio la raspi, me enciende la TV aunque no haya nadie en casa.
En mi caso no quiero que la raspi encienda otros electrodomésticos. Así que:

Ajustes > Sistema > Entrada > Periféricos > CEC
screenshot007.png
No tienes los permisos requeridos para ver los archivos adjuntos a este mensaje.
Avatar de Usuario
danpacu
Pi Beta
Pi Beta
Mensajes: 179
Registrado: 27 Nov 2019, 21:42

Hola, @egrueda. Perdona el retraso en contestar. En llegar a casa miraré los ajustes de kodi que me mencionas y comentaré algo. Muy amables los dos en guiarme. Gracias.
Avatar de Usuario
danpacu
Pi Beta
Pi Beta
Mensajes: 179
Registrado: 27 Nov 2019, 21:42

Buenos días. Hoy pasa algo raro.
Me deja conectarme por ssh pero no puedo lanzar comandos.
Me da esta salida:
sudo service plexmediaserver stop
Failed to connect to bus: Conexión rehusada
Failed to connect to bus: Conexión rehusada
POr vnc no me deja coenctarme. AL elegir la fuente en la tele, para acceder a la raspi, no me deja ver nada - pantalla en negro.
TOca resetear, pero no entiendo el porque de lo sucedido. Anoche resetee la raspi normal, sin problemas. Hoy al llegar a casa del trabajo, me encuentro así.....


Edit:
Aqui: https://pastebin.com/BTF4ga5R el run.log por si ayuda.... del directorio .cache/lxsession/LXDE-pi (si bien me acuerdo la ruta).
Avatar de Usuario
egrueda
Pi God
Pi God
Mensajes: 2086
Registrado: 10 Feb 2017, 19:31

Cambia el

Código: Seleccionar todo

sudo service plexmediaserver stop
por

Código: Seleccionar todo

sudo systemctl stop plexmediaserver
Avatar de Usuario
danpacu
Pi Beta
Pi Beta
Mensajes: 179
Registrado: 27 Nov 2019, 21:42

Hecho. Pro cierto, si el culpable es el plex, y lo tengo parado, entonces que hago??
Por otro lado le quite el screensaver a la raspi para ver si eso era también una posible causa de errores. Bien, mal??
Responder