Linux Ubuntu Mate en Raspberry PI 4... No me deja instalar nada...

Sección para los diferentes SO de nuestras placas
Responder
Avatar de Usuario
raspberriano
Pi Newbie
Pi Newbie
Mensajes: 4
Registrado: 11 Oct 2020, 11:23
Agradecido: 2 veces
Agradecimiento recibido: 0

Buenas a todos!

Soy nuevo con esto de las raspberry y linux pero sinceramente creía que esto tenía un poco más de margen. Os pongo un ejemplo, iba a ponerme raspian OS pero como es de 32 bits y necesito linux de64 pues me puse Linux Mate 64 bits.
A la hora de instalar cosas me ha ido más o menos, pero la cosa llega cuando intento instalar teamviewer, vnc server, any desk o algunos otros programas...
Con el comando uname -a veo que la arquitectura que tengo es:
aarch64
Y por ejemplo he probado a instalar cada uno de esos programas .deb tanto en x64 como en x32 como en armhf y no hay forma de instalarlo.
He probado a definir diferentes arquitecturas así:
https://www.diversidadyunpocodetodo.com ... 386-amd64/
Pero luego me pide que instale paquetes tales como:

-------------------------------------------------------------------------
anydesk:armhf depende de libc6 (>= 2.7).
anydesk:armhf depende de libgcc1 (>= 1:4.1.1).
anydesk:armhf depende de libglib2.0-0 (>= 2.16.0).
anydesk:armhf depende de libgtk2.0-0 (>= 2.20.1).
anydesk:armhf depende de libstdc++6 (>= 4.1.1).
anydesk:armhf depende de libx11-6.
anydesk:armhf depende de libxcb-shm0.
anydesk:armhf depende de libxcb1.
anydesk:armhf depende de libpango-1.0-0.
anydesk:armhf depende de libcairo2.
anydesk:armhf depende de libxrandr2 (>= 1.3).
anydesk:armhf depende de libx11-xcb1.
anydesk:armhf depende de libxtst6.
anydesk:armhf depende de libxfixes3.
anydesk:armhf depende de libxdamage1.
anydesk:armhf depende de libxkbfile1.
anydesk:armhf depende de libegl1-mesa.
anydesk:armhf depende de libgl1.
-------------------------------------------------------------------------

SI lo instalo con: sudo apt-get install -y libc6 me dice que ya tengo la versión más reciente de ese paquete instalada.
Ahora pruebo con:
sudo apt --fix-broken install
Y me dice que la app que se ha instalado va a eliminar 1 paquete y me borra la aplicación.

NO hay forma y así me ocurre con todos los programas que quiero instalar, ni teamviewer, ni cambiando arquitectura, ni probando diferentes archivos de instalación en x64, x32 o arquitectura armhf... en fin... que no encuentro forma la verdad de hacer que se instalen los programas como sí normalmente se instalan en otro tipo de ordenadores con otro procesador, pero la Raspberry PI 4 con linux mind me está dando muchos dolores de cabeza...

Si alguien supiera alguna solución se lo agradecería...
Avatar de Usuario
egrueda
Pi God
Pi God
Mensajes: 2229
Registrado: 10 Feb 2017, 19:31
Agradecido: 0
Agradecimiento recibido: 27 veces

raspberriano escribió: 12 Oct 2020, 00:47Soy nuevo con esto de las raspberry y linux pero sinceramente creía que esto tenía un poco más de margen.
Lo del margen es la cosa más graciosa que he leído hoy :guiño2 :guiño2 :guiño2
Te has comprado una raspi, ¡bienvenido al mundo DIY! Has elegido no coger atajos, aprender una arquitectura nueva, aprender linux, perder muchas (muuuchas) horas leyendo documentación y aprender muchísimo. Y eso conlleva una curva de aprendizaje, y a esforzarse y a dedicarle mucho tiempo.
Si no sabes nada de raspberry pi y nada de linux, entonces el comienzo te costará, porque tendrás que asimilar conceptos muy distintos pero a la vez muy básicos en computación y en sistemas linux. E insisto, no hay atajos, has elegido el camino largo.
¿Que no tiene margen? En este punto quizá no seas capaz de ver cuánto margen tiene una raspi, o cuánto margen tiene un sistema linux. Pero eres tú quien debe darle ese margen, a la raspi no le pasa nada, jajaja
raspberriano escribió: 12 Oct 2020, 00:47iba a ponerme raspian OS pero como es de 32 bits y necesito linux de64
Puedes probar con esta versión, funciona bastante bien con la raspi4 de 8gb:
https://www.raspberrypi.org/forums/view ... p?t=275370
raspberriano escribió: 12 Oct 2020, 00:47Con el comando uname -a veo que la arquitectura que tengo es: aarch64
Vale pero no confundas el kernel que tienes instalado con la arquitectura armhf ;-)
raspberriano escribió: 12 Oct 2020, 00:47Y por ejemplo he probado a instalar cada uno de esos programas .deb tanto en x64 como en x32 como en armhf y no hay forma de instalarlo.
Siendo humildes deberías decir que no sabes cómo instalarlo, porque claro que hay forma.
Desde luego los x32 y los x64 no te van a funcionar
raspberriano escribió: 12 Oct 2020, 00:47SI lo instalo con: sudo apt-get install -y libc6 me dice que ya tengo la versión más reciente de ese paquete instalada.
Por lo general te indica qué paquetes necesita *ese* paquete que estás instalando, pero no te indica si ese es el paquete que necesitas.
Quizá el problema sea de compatibilidad con el OS: "Only Raspbian is supported"
raspberriano escribió: 12 Oct 2020, 00:47Ahora pruebo con: sudo apt --fix-broken install Y me dice que la app que se ha instalado va a eliminar 1 paquete y me borra la aplicación.
Bueno, ha hecho exactamente lo que se espera de ese comando.
raspberriano escribió: 12 Oct 2020, 00:47no encuentro forma la verdad de hacer que se instalen los programas como sí normalmente se instalan en otro tipo de ordenadores con otro procesador, pero la Raspberry PI 4 con linux mind me está dando muchos dolores de cabeza...
Somos cientos de miles de personas que usamos raspi a diario y no nos duele la cabeza. Y te vuelvo a soltar el rollo de la curva de aprendizaje.
Es fácil, por lo general, instalar software y hacer millones de cosas, siempre sabiendo lo que estamos haciendo, dónde estamos y qué requisitos tenemos.
Guarda el ibuprofeno para más tarde jajaja
raspberriano escribió: 12 Oct 2020, 00:47Si alguien supiera alguna solución se lo agradecería...
La solución es que tengas paciencia y aprendas un poquito cada día. ¡Animo!

P.D. Te recomiendo que instales el OS de 64 bits del enlace anterior, aunque sea beta, para evitar complicaciones de documentación oficial.
Responder