1 failed device

Sección General del foro
Responder
kiftren
Pi Alpha
Pi Alpha
Mensajes: 12
Registrado: 01 Jun 2020, 22:16

Buenas noches.
Soy novato en el foro e inicio este post ya que llevo varios días intentando Retropie y Blast 16 sin éxito. En primer lugar formateo la microSD con SD Card Formatter, bien formato normal, bien formato rápido. A continuación ejecuto BalenaEtcher como administrador para copiar Retropie, Blast 16, SNESES,... en mi tarjeta SanDisk Ultra de 32 GB. Siempre obtengo el mismo mensaje al final del proceso: "1 Failed device".
He probado con varias tarjetas microSD en todas ocurre lo mismo, una de ellas la he metido en mi móvil para comprobar que funciona correctamente y lo hace, por lo que descarto fallo de tarjeta. Tampoco es es adaptador ya que me ocurre lo mismo poniendo el adaptador SD y metiendolo en su slot o con el adaptador microSD por USB que tengo.
No se que estoy haciendo mal, ¿alguien tiene idea de que me puede estar pasando? Adjunto foto del fallo.
Gracias por vuestra ayuda.
No tienes los permisos requeridos para ver los archivos adjuntos a este mensaje.
Avatar de Usuario
egrueda
Pi God
Pi God
Mensajes: 2089
Registrado: 10 Feb 2017, 19:31

¿Y has probado con otro programa, como por ejemplo el programa oficial "imager" de Raspberry?
Avatar de Usuario
wigum
Pi Alpha
Pi Alpha
Mensajes: 20
Registrado: 20 Ene 2018, 22:18

Si la formateas por ejemplo en fat, puedes guardar en ella archivos desde el explorador y después leerlos sin problema?
Última edición por wigum el 02 Jun 2020, 12:36, editado 1 vez en total.
Avatar de Usuario
egrueda
Pi God
Pi God
Mensajes: 2089
Registrado: 10 Feb 2017, 19:31

Por cierto, ¿por casualidad windows te ha creado la carpeta oculta "System Volume Information" en la tarjeta?
A lo mejor es por eso que la validación falla, aunque el grabado haya sido correcto.
kiftren
Pi Alpha
Pi Alpha
Mensajes: 12
Registrado: 01 Jun 2020, 22:16

Muchas gracias por vuestra ayuda egrueda y wigum.

Creo que finalmente egrueda tiene razón,en la tarjeta veo la carpeta "System Volume Information", aunque no está oculta, es una carpeta de solo lectura. Supongo que el problema se resuelve tan fácil como borrar esa carpeta, pero me pregunto si hay alguna forma de impedir a Windows que la escriba para que el Etcher me de el resultado real de la escritura, no vaya a ser que ocurra un fallo real y piense que este pseudofallo sin importancia.

De nuevo muchas gracias a ambos y perdonar la tardanza en responder
Avatar de Usuario
egrueda
Pi God
Pi God
Mensajes: 2089
Registrado: 10 Feb 2017, 19:31

Jajaja, sabía que podría ser eso.
ciertamente no es ningún problema, la puedes borrar o la puedes dejar, no vas a tener problema de funcionamiento.

Existe una forma de deshabilitar ese comportamiento en Windows, "Disable SVI", aunque no recuerdo de memoria cómo se hace.
kiftren
Pi Alpha
Pi Alpha
Mensajes: 12
Registrado: 01 Jun 2020, 22:16

Con esa información tengo suficiente para poder sacarlo. Muchas gracias por tu ayuda, llevaba un par de semanas dándole vueltas al asunto sin encontrar la causa.
kiftren
Pi Alpha
Pi Alpha
Mensajes: 12
Registrado: 01 Jun 2020, 22:16

Para finalizar el post, el problema era definitivamente la carpeta "System Volume Information" que escribe Windows por su cuenta. Por más que he intentado no he conseguido configurar que Windows no escriba esa carpeta en USBs ni en SDs. La solución final, como se decia más arriba es utilizar el programa "imager" de Raspberry. Este programa escribe la SD y posteriormente al comparar se ve que tiene en consideración que Windows te mete esa carpeta a capón y no te lanza error, a pesar de que en el explorador de archivos puedes verla ahí.

Si te molesta esa carpeta, una vez copiada correctamente la tarjeta eliminar esa carpeta es tan sencillo como meter por línea de comando en la unidad correspondiente:
rmdir “system volume information” /s /q
Avatar de Usuario
egrueda
Pi God
Pi God
Mensajes: 2089
Registrado: 10 Feb 2017, 19:31

¡Gracias por la información!
¿Con qué versión de Windows te ocurre esto?
kiftren
Pi Alpha
Pi Alpha
Mensajes: 12
Registrado: 01 Jun 2020, 22:16

Windows 7 Home Premium
Avatar de Usuario
egrueda
Pi God
Pi God
Mensajes: 2089
Registrado: 10 Feb 2017, 19:31

kiftren escribió:
07 Jun 2020, 12:59
Windows 7 Home Premium
Puedes editar el registro:
HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows

Y crear un nuevo valor, de tipo DWORD
Nombre: DisableRemovableDriveIndexing
Valor: 1
kiftren
Pi Alpha
Pi Alpha
Mensajes: 12
Registrado: 01 Jun 2020, 22:16

Gracias!!!
Responder