Emuladores para monedero

Muchas gracias por contestar tan rápido, y […]

presentacion

hola, soy luylly77, me comentaron de este foro par[…]

Hola, Ya sé que no es Raspberry, pero como[…]

Bueno parece que este tema ya hace tiempo que es[…]

Soporte General para RecalBox
Por F0XHOUND
Pi Alpha
#76683
Buenas. Llevo pocas semanas con recalbox y la raspberry pi3.
Buscando información he conseguido hacer funcionar todos los emuladores que lleva incluyendo amiga, msx o mame.

El problema viene con PSP, le meto las .iso las detecta pero a la hora de arrancarlas se queda unos segundos pantalla en negro y vuelve al menu.

Con la ultima actualizacion del 20-04-18 lo probe y funcionó a la primera sin hacer nada lo que pense que era un bug de la version anterior. Hoy lo pruebo y vuelve a hacer lo mismo.

Intento modificar el recalbox.conf con la linea psp.video= añadiendo los 3 parametros que he visto en otras lineas y nada.
He entrado en las carpetas de sistema y he probado borrar los .ini del emulador sin exito.

Alguna idea de lo que puede ocurrir? Gracias.
Por F0XHOUND
Pi Alpha
#76727
Tiene algo que ver con la resolución. Si enciendo la raspberry con la TV apagada se ve que no puede detectarla y al encenderla veo recalbox a una resolucion muy baja y ahi es cuando arranca el emulador de PSP.
Sin embargo cuando salgo al menu e intento arrancar el mismo u otra ISO de PSP me vuelve a ocurrir.

Diria que es algun modo de video que al intentar ejecutarlo hace que ya no vuelve a funcionar mas ese emulador.
Por cornholio
Pi Beta
#76824
Tienes que bajar el escalado de vídeo a 640x480.
Aparte tendrás que hacer un overclock para que te funcionen algunos juegos.
Por F0XHOUND
Pi Alpha
#76954
Sigo probando de todo y de momento no obtengo solución. Si alguien sabe como solucionarlo estaria muy agradecido
Por totalfroggy
Pi Newbie
#77419
Tengo el mismo problema que el compañero. Tras la última actualización de versión, los juegos de psp no cargan (vuelve a pantalla inicial). No hay bios que añadir, y no entiendo por que ahora fallan los juegos.

Saludos.
Por jlbosch78
Pi Beta
#77500
Prueba a reemplazar el archivo ppsspp.ini por el que te adjunto. Resguarda el original por cualquier inconveniente. Comentanos el resultado.

Saludos.
No tienes los permisos requeridos para ver los archivos adjuntos a este mensaje.
Por Apolocris
Pi Alpha
#77532
hay alguna solución para esto? Alguien me puede facilitar una bios de psp? llevo un buen rato por el foro y no encuentro nada
Por F0XHOUND
Pi Alpha
#77560
Nada. Sigue sin funcionar. Sustituido el INI en recalbox/share/system/configs/ppsspp/
Alguna idea más ?
Por F0XHOUND
Pi Alpha
#77562
He encontrado este log tras intentar lanzar el emulador sin exito.

08:05:645 Core/Config.cpp:941 I[LOAD]: Loading controller config: /recalbox/share/system/configs/ppsspp/PSP/SYSTEM/controls.ini
glGetError 0x500
08:05:974 Core/System.cpp:387 I[BOOT]: PPSSPP unknown
08:05:975 Common/MsgHandler.cpp:54 E[*]: Warning: Failed to map 256 MB of memory space: Cannot allocate memory
08:05:975 Core/MemMap.cpp:271 I[MM]: Memory system initialized. Base at (nil) (RAM at @ 0x8000000, uncached @ 0x8000000)
/usr/bin/PPSSPPSDL: relocation error: /usr/bin/PPSSPPSDL: symbol , version GCC_3.0 not defined in file libgcc_s.so.1 with link time reference
Por F0XHOUND
Pi Alpha
#77622
Parece ser que el error de memoria es por RAM. He averiguado que la raspberry pi3 model 2 tiene 1 gb de RAM y Recalbox la parte en 500mb para sistema y los otros para video. Segun pone en otros foros hay que deshabilitar cosas de Recalbox o cambiar de tema a uno que consuma menos RAM para lograr lanzarlo.
Voy a hacer pruebas y si consigo algo lo comparto.
Por F0XHOUND
Pi Alpha
#77660
Desde ajustes avanzados he bajado la opcion de VRAM (RAM de video) a 150 y el juego de PSP arracó sin problemas. Sin embargoal salir y volver a ejecutar otro volvio a pasar lo mismo.
Por Juantxo
Pi Alpha
#77908
Hay solucion para esto? me ocurre lo mismo.No entiendo que coño pasa ya que antes cargaban sin problemas.
Saludos.
Por F0XHOUND
Pi Alpha
#79803
He averiguado lo que ocurre, estuve monitorizando los datos de recalbox con el movil y me di cuenta que quedaba muy poca RAM disponible nada mas arrancar.
Y es que recalbox tiene configurado por defecto la mitad de su RAM para utilizarla como video y no deja suficiente para arrancar al menos el emulador de PSP.
Es posible que otra gente que no tenga tan sobrecargado su Recalbox no tenga este problema. Yo lo tengo muy lleno.

La solucion pasa por editar el fichero config.txt de la partición principal y visible en un PC insertando la microSD, localizar la linea gpu_mem_1024= si tu raspberry es de 1Gb de RAM y cambiar 512 por 320. He probado varios parametros y parece que el más estable es este.

El cambio no parece afectar a los emuladores N64, DC o PSX que he probado pero si que permite cargar las isos de PSP.
Recomendaria hacer un respaldo de este config.txt por si hubiera algun problema y haya que revertirlo. A mi me ha funcionado bien y ya llevo un par de semanas así.

Comentar vuestros resultados.
Por totalfroggy
Pi Newbie
#80972
Muy buenas! por mi parte decirte que he tenido infinitos problemas con el emulador PSP al actualizar de versiónes el recalbox. Tras investigar los logs, descubrí que la VRAM está tan llena con los temas Alekfull que no era posible lanzarlos.

Mi recomendación es usar temas ligeros, y a ser posible y si conoces el tema, usar la misma musica para los emuladores, ya que el cambiar de musica, imagen, la ruleta...todo consume vram de la consola que al final impide lanzar los juegos correctamente.

Yo hace tiempo que dejé de actualizar el recal por que cada vez que lo hacia, era un quebradero de cabeza. Pierdo Netplay y algunos emus como daphne o thompson, pero para lo que exprimo la rasp, creo que es bastante.

Por otro lado, para mejorar la emulación en PSP, voy a indagar con batocera y en ultimo caso, a usar hyperspin en PCx86.

Saludos!